MK Data failed to connect ssl

MK Data failed to connect ssl




Failed to access the WSDL at: https://www.mkdenial.com/dplv3_1.asmx?wsdl. It failed with:
    Got sun.security.validator.ValidatorException: PKIX path building failed:



download:



On the server, put the file in:
\\PPGlobal\Tomcat\webapps\pp\WEB-INF\lib


On every client, put the file in:
\\PPGlobal\Client

NOTE:  if there is already a  phosphate.jar file, just overwrite it.




since we made this functionality change in this 6446 release, for the customers who are upgrading to 6446, they will have to change the phosphate jar once on clients as well; only for this time. If they had installed the 6446 setup, then no change was needed.
But, after this, they will never have to make any changes on the client machines. Whatever certificates users want to add (even for MK Data certificates), they will just have to make that change on the PassagePoint server side. On the client machines, certificates will automatically get accepted.